CreateElectricalConnector Method (Document, ElectricalSystemType, Reference, Edge)


Connector Element Create Electrical Connector(Document, Electrical System Type, Reference, Edge) Method

Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ConnectorElement CreateElectricalConnector(
	Document document,
	ElectricalSystemType electricalSystemType,
	Reference planarFace,
	Edge edge
)

Parameters

document Document
The document to add the connector to.
electricalSystemType ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The electrical ConnectorElement.
Exceptions
Exception Condition
ArgumentException The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also