ExternalResourceSubFolder Class


External Resource Sub Folder Class

Data that describes a remote folder to be shown in the file browser dialog
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceSubFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceSubFolder : IDisposable

The ExternalResourceSubFolder type exposes the following members.

Constructors
Name Description
Public method ExternalResourceSubFolder Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.
Public method ExternalResourceSubFolder(String, String) Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.
Top
Properties
Name Description
Public property FolderName Folder displayed name.
Public property IconPath The path of the resource icon.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExternalResourceSubFolder
Top
See Also