ReferenceIntersector Constructor (View3D)


Reference Intersector(View 3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ReferenceIntersector(
	View3D view3d
)

Parameters

view3d View3D
The view in which to find references.
Exceptions
Exception Condition
ArgumentException Returns true if the view is not a view template.
ArgumentNullException A non-optional argument was null
See Also