FilterStringRuleEvaluator Class


Filter String Rule Evaluator Class

Base for all classes that compare string values from Revit to a user-supplied filter value
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterStringRuleEvaluator
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterStringRuleEvaluator : IDisposable

The FilterStringRuleEvaluator type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FilterStringRuleEvaluator
Public method Evaluate Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Top
See Also
Inheritance Hierarchy