SetServicesToLoad Method


Fabrication Configuration Set Services To Load Method

Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetServicesToLoad(
	IList<int> serviceIds
)

Parameters

serviceIds IList Int32

Return Value

Boolean
Returns true if successful. May fail if any service currently loaded is not included and is in use so cannot be unloaded.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also