AlignByFace Method


Rebar Propagation Align By Face Method

It will copy the source rebars, will align them to the destination face based on the source face and adapt them to destination host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> AlignByFace(
	Document doc,
	IList<Rebar> sourceRebars,
	Reference sourceFaceReference,
	Reference destinationFaceReference
)

Parameters

doc Document
A document.
sourceRebars IList Rebar
The rebars that will be propagated. All of them must be from the same host as the source face reference.
sourceFaceReference Reference
A reference to a face in the source host.
destinationFaceReference Reference
A reference to a face in the destions host.

Return Value

ISet ElementId
The newly created rebars.
Exceptions
Exception Condition
ArgumentException The element that contains the destinationFaceReference is not a valid rebar host. -or- The rebars should be from the same host as the source face reference. -or- The rebars that are group members can't be propagated. -or- The references should represent faces that have same type of surface. -or- The source and destination face references should be different. -or- This method uses its own transaction, so it's not permitted to be invoked in an active transaction.
ArgumentNullException A non-optional argument was null
Remarks

The source and destination hosts represented by the source and destination references can be the same element or can be difereent elements. They can also be of different categories

The destination host must be able to host rebar.

The source rebars should not be gourp members.

This method uses its own transaction, so it's not permitted to be invoked in an active transaction.

See Also