Subtraction Operator


XYZ Subtraction Operator

Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static XYZ operator -(
	XYZ left,
	XYZ right
)

Parameters

left XYZ
The first vector.
right XYZ
The second vector.

Return Value

XYZ
The vector equal to the difference between the two source vectors.
Exceptions
Exception Condition
ArgumentNullException Thrown when left or right is .
Remarks
The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.
See Also