Index |
A stream that can be used to write IndexLine primitives into an IndexBuffer

System Object
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IndexStreamLine type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | AddLine | Inserts a IndexLine segment into the stream and associated buffer. |
![]() | AddLines | Inserts multiple IndexLine segments into the stream and associated buffer. |