Index |
A stream that can be used to write IndexLine primitives into an IndexBuffer

System Object
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IndexStreamLine type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from IndexStream ) |

Name | Description | |
---|---|---|
![]() | AddLine | Inserts a IndexLine segment into the stream and associated buffer. |
![]() | AddLines | Inserts multiple IndexLine segments into the stream and associated buffer. |
![]() | Dispose | (Inherited from IndexStream ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |