FamilyInstanceCreationData Class


Family Instance Creation Data Class

A class which wraps the arguments of FamilyInstance for batch creation.
Inheritance Hierarchy
System Object
Autodesk.Revit.Creation FamilyInstanceCreationData

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyInstanceCreationData

The FamilyInstanceCreationData type exposes the following members.

Constructors
Name Description
Public method FamilyInstanceCreationData(Object) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(FamilySymbol, IList XYZ ) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(Face, Line, FamilySymbol) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) Initializes a new instance of the FamilyInstanceCreationData class
Public method FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) Initializes a new instance of the FamilyInstanceCreationData class
Top
Properties
Name Description
Public property Axis Get or set the axis of the FamilyInstance
Public property RotateAngle Get or set the rotate angle of the FamilyInstance
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also