GBXMLExportOptions(IList<ElementId>, IList<ElementId>) Constructor


GBXMLExport Options(IList Element Id , IList Element Id ) Constructor

Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public GBXMLExportOptions(
	IList<ElementId> massZoneIds,
	IList<ElementId> massIds
)

Parameters

massZoneIds IList ElementId
Indicates the mass zones to analyze in the exported gbXML.
massIds IList ElementId
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also