UnitFormatUtils Class


Unit Format Utils Class

A utility class for formatting and parsing numbers with units.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB UnitFormatUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UnitFormatUtils

The UnitFormatUtils type exposes the following members.

Methods
Name Description
Public method Static member Format(Units, ForgeTypeId, Double, Boolean) Formats a number with units into a string.
Public method Static member Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) Formats a number with units into a string.
Public method Static member TryParse(Units, ForgeTypeId, String, Double ) Parses a formatted string into a number with units if possible.
Public method Static member TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double ) Parses a formatted string into a number with units if possible.
Public method Static member TryParse(Units, ForgeTypeId, String, Double , String ) Parses a formatted string into a number with units if possible.
Public method Static member TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double , String ) Parses a formatted string into a number with units if possible.
Top
See Also