BuiltInFailures.SketchFailures Class


Built In Failures Sketch Failures Class

Failures about Sketch.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures SketchFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SketchFailures

The BuiltInFailures SketchFailures type exposes the following members.

Properties
Name Description
Public property Static member AreaLoadNoForce Area Load can't have all force components equal to zero.
Public property Static member AxisNotSpecified Axis of revolution not specified.
Public property Static member BadNosingProfile Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
Public property Static member BadRailingsProfile Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
Public property Static member BeamDirectionNotSpecified Beam direction not specified.
Public property Static member BeamDirectionNotSpecifiedError Beam direction not specified.
Public property Static member BentFabricSheetClosedLoopInSketch The bend profile cannot contain a closed loop. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
Public property Static member BentFabricSheetEmptySketch The bend profile requires at least one segment to be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
Public property Static member BentFabricSheetInvalidElementInSketch Arcs in a bend profile must be separated from one another with a connected straight segment. The bend profile cannot start or end with an arc. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
Public property Static member BentFabricSheetLinesOverlapOrIntersect Segments in a bend profile cannot overlap, intersect, or be collinearly contiguous. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
Public property Static member BentFabricSheetManyLoopsInSketch The bend profile cannot contain two or more disconnected segments. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
Public property Static member BentFabricSheetTooShortSegments A segment in the bend profile is too short to apply the wire bend diameter. The bent fabric sheet of the selected type cannot be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
Public property Static member BoundaryNoOverlap The split sketch is out of the boundary of split element sketch..
Public property Static member BuildingPadNoSurface A Pad can't extend beyond the edge of a Toposurface.
Public property Static member BuildingPadNoSurfaceError A Pad can't extend beyond the edge of a Toposurface.
Public property Static member CannotChangeUserSketchPlane Can't change plane of [Element Name] Sketch.
Public property Static member CannotChangeUserSketchPlaneError Can't change plane of [Element Name] Sketch.
Public property Static member CannotChangeWorkplaneVisibility Can't change Work Plane Visibility.
Public property Static member CannotComputeRailingsElevation Can't compute Railings Elevation Profile.
Public property Static member CannotComputeRailingsElevationError Can't compute Railings Elevation Profile.
Public property Static member CannotComputeRailingsElevationWarn Can't compute Railings Elevation Profile
Public property Static member CannotConvertSketch Can't convert Sketch to Rebar Shape.
Public property Static member CannotDrawExtrusionRoof Can't make extruded roof.
Public property Static member CannotDrawProfileRoof Can't make footprint roof.
Public property Static member CannotGetSketchReferences Cannot find references to dimension sketch.
Public property Static member CannotHaveArcs Sorry, we can't use arcs here.
Public property Static member CannotHaveArcsPath3d Sorry, we can't use arcs here.
Public property Static member CircleMultiPlanarShapeInSketch A circle can't be converted to multiplanar shape.
Public property Static member ClosedProfileRoof Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
Public property Static member ConstantHeightNotParallel Constant-height-defining lines must be parallel.
Public property Static member ConstantHeightNotParallelError Constant-height-defining lines must be parallel.
Public property Static member ContainedInOtherLoops When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
Public property Static member ConvertSplineToLineFailed Failed to convert spline to straight line
Public property Static member CurveFromPickedFailed Can't create boundary from pick.
Public property Static member CurveIntersectsCutFace The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
Public property Static member CurveIntersectsSplitFace The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
Public property Static member CurveTooShort Line is too short.
Public property Static member DifferentOffsets Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
Public property Static member ElementsSketchTooLarge The sketch defining the highlighted element is too large.
Public property Static member ElevationSketchNotAllowed Wall in a family can't have an elevation profile.
Public property Static member EndsNotOnCutFace Ends of the sketched loop do not lie on the boundary of the face being modified.
Public property Static member EndsNotOnEdge Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
Public property Static member FloorCannotAddDirectionCurve Cannot add the direction curve in the floor sketch.
Public property Static member FloorCannotAddDirectionCurveError Cannot add the direction curve in the floor sketch.
Public property Static member FloorDirectionNotSpecified Structural floor span direction not specified.
Public property Static member FloorManyDirectionCurves More than one span direction curve specified.
Public property Static member InvalidAreaLoadSketch Area Load has invalid Sketch.
Public property Static member InvalidCropAreaSketch Crop area sketch can either be empty or include one closed, not self-intersecting loop.
Public property Static member InvalidCropAreaSketchRegen Crop area sketch can either be empty or include one closed, not self-intersecting loop.
Public property Static member InvalidElevationSketch Elevation Profile sketch is invalid.
Public property Static member InvalidElevationSketchError Elevation Profile sketch is invalid.
Public property Static member InvalidProfile One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
Public property Static member InvalidProfileError One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
Public property Static member InvalidRoofCurveloop Base sketch for roof is invalid.
Public property Static member InvalidRoofCurveloopError Base sketch for roof is invalid
Public property Static member InvalidRoofCurveloopFailure Base sketch for roof is invalid
Public property Static member InvalidSketch Sketch is invalid.
Public property Static member InvalidSketchError Sketch is invalid.
Public property Static member InvalidSketchForBuildingpad Pad sketch is invalid.
Public property Static member InvalidSketchForCeiling Ceiling sketch is invalid.
Public property Static member InvalidSketchForFloor Floor sketch is invalid.
Public property Static member InvalidSketchForRoofsoffit Roof Soffit sketch is invalid.
Public property Static member InvalidSketchForToposolid Toposolid sketch is invalid.
Public property Static member InvalidSketchPath3d Sketch is invalid.
Public property Static member LandingNotEnoughBoundaryCurves Sketch landing require boundaries
Public property Static member LandingTwoManyLoops Sketch landing can only have one closed loop
Public property Static member LinesOverlap Cannot have overlapping lines.
Public property Static member LinesOverlapError Cannot have overlapping lines.
Public property Static member LinesOverlapPath3d Cannot have overlapping lines.
Public property Static member LoopIntersect Lines cannot intersect each other. The highlighted lines currently intersect.
Public property Static member LoopIntersectError Lines cannot intersect each other. The highlighted lines currently intersect.
Public property Static member LoopIntersectPath3d Lines cannot intersect each other. The highlighted lines currently intersect.
Public property Static member LoopsOutsideFaceSplit Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
Public property Static member LoopsOutsideFaceSplitterTooShort Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
Public property Static member ManyCCWLoops Area defined by sketch must be connected.
Public property Static member ManyCCWLoopsError Area defined by sketch must be connected.
Public property Static member ManyDirectionCurves More than one direction curve specified.
Public property Static member ManyDirectionCurvesError More than one direction curve specified.
Public property Static member MissingLapInSketch Rebar Sketch does not have lapped lengths. A circular shaped Rebar needs overlapping legths. Please overlap one of the ends of the circular Rebar Sketch.
Public property Static member MoreThanOneAxis More than one axes of revolution.
Public property Static member MutipleStairsPathInOneRunFailure Each stairs run can only have one stairs path.
Public property Static member NestedLoops Cannot have nested loops.
Public property Static member NoLoops Sketch is empty.
Public property Static member NoLoopsError Sketch is empty.
Public property Static member NoLoopsPath3d Sketch is empty.
Public property Static member NonMonotoneRoof All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
Public property Static member NoPlane Highlighted geometry no longer determines a plane
Public property Static member NotOneCCWLoop This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
Public property Static member NotOneCurve More than one curve not allowed.
Public property Static member NotOneCurveError More than one curve not allowed.
Public property Static member NotOneCurvePath3d More than one curve not allowed.
Public property Static member NotOneLoop More than one loop not allowed.
Public property Static member NotOneLoopPath3d More than one loop not allowed.
Public property Static member OpenAreaLoadLoop Area Load Sketch can't contain open loops.
Public property Static member OpenLoop Lines must be in closed loops. The highlighted lines are open on one end.
Public property Static member OpenLoopError Lines must be in closed loops. The highlighted lines are open on one end.
Public property Static member OpenLoopPath3d Lines must be in closed loops. The highlighted lines are open on one end.
Public property Static member PathCannotBeClosedLoop Path cannot be a closed loop.
Public property Static member PathCannotBeClosedLoopPath3d Path cannot be a closed loop.
Public property Static member PathReinforcementClosedLoop Sketch contains a closed loop. Can't create Path Reinforcement.
Public property Static member PathReinforcementEmptySketch Sketch is empty. Can't create Path Reinforcement.
Public property Static member PathReinforcementManyLoops Sketch contains more than one chain. Can't create Path Reinforcement.
Public property Static member PlanarMultiPlanarShapeInSketch The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
Public property Static member RailingDoublyConnected Railings hosted on Stairs must form a single, open, connected line.
Public property Static member RailingDoublyConnectedError Railings hosted on Stairs must form a single, open, connected line.
Public property Static member RailingNotConnected The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
Public property Static member RailingNotConnectedError The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
Public property Static member RebarEmptySketch Rebar Sketch is empty. Can't create Rebar.
Public property Static member RebarEmptySketchError Rebar Sketch is empty. Can't create Rebar.
Public property Static member RebarManyLoops Rebar Sketch contains more than one loop. Can't create Rebar.
Public property Static member RebarManyLoopsError Rebar Sketch contains more than one loop. Can't create Rebar.
Public property Static member RebarSystemDirectionNotSpecified Major direction not specified.
Public property Static member RebarSystemDirectionNotSpecifiedError Major direction not specified.
Public property Static member RunInvalidSketch Invalid sketch, can't create run by this sketch
Public property Static member RunNotEnoughBoundaryCurves Sketch run require boundaries (chains of one or more Boundary Lines)
Public property Static member SculptingCurvesCannotFormClosedLoop Curves cannot form a closed loop.
Public property Static member SculptingCurvesCrossAxis The highlighted curves cross the axis.
Public property Static member SculptingCurvesTouchAxis The highlighted curves touch the axis.
Public property Static member SculptingLoopsOnBothSidesOfAxis All curves must be on the same side of the axis.
Public property Static member SculptingSingleLineLoopLiesOnAxis The highlighted lines lie on the axis.
Public property Static member ShortCurveInSketch The sketch contains an extremely short line.
Public property Static member ShortCurveInSketchRoof The sketch contains an extremely short line.
Public property Static member SiteCannotDrawSurfaceBoundary Cannot make surface with specified boundary.
Public property Static member SketchedRunInvalidPath Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.
Public property Static member SketchedShapeNotAvailable Skeched shape is not available for this type of element.
Public property Static member SketchFailurePlanes Sketch is no longer parallel to its defining plane
Public property Static member SketchingInTheWrongView Detail sketch is only editable in [View Type].
Public property Static member SketchingInWrongView Detail sketch is not editable in this view.
Public property Static member SketchOverconstrained Sketch is overconstrained.
Public property Static member SketchOverconstrainedError Sketch is overconstrained.
Public property Static member SketchOverconstrainedWarn Sketch is overconstrained.
Public property Static member SketchTooLarge Sketch is too large.
Public property Static member SketchWasDeleted Sketch was deleted.
Public property Static member StairClosedBoundaries Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
Public property Static member StairClosedBoundariesError Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
Public property Static member StairNotEnoughBoundaryCurves Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
Public property Static member StairNotEnoughBoundaryCurvesError Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
Public property Static member StairNotEnoughRiserCurves Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
Public property Static member StairNotEnoughRiserCurvesError Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
Public property Static member StairOnlyOneConnectedBoundary Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
Public property Static member StairOnlyOneConnectedBoundaryError Stairs require no less than two boundaries (chains of one or more Boundary Lines).
Public property Static member StairRiserDoesntIntersectBoundary The line representing the top of a riser does not intersect one or both of the boundary lines.
Public property Static member StairRiserDoesntIntersectBoundaryError The line representing the top of a riser does not intersect one or both of the boundary lines.
Public property Static member StairTooManyConnectedBoundaries Stairs require no more than two boundaries (chains of one or more Boundary Lines).
Public property Static member StairTooManyConnectedBoundariesError Stairs require no more than two boundaries (chains of one or more Boundary Lines).
Public property Static member SubregionNoHostSurf A Subregion cannot be created outside the boundary of a Toposurface. A Subregion should be completely inside a Toposurface or overlap a Toposurface.
Public property Static member SuggestMakingFamilyNonParametric Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
Public property Static member SuspendedSketchWarn Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
Public property Static member TooFewParamsForSketch The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
Public property Static member TooManyElementsInSketch This sketch is large. Performance will improve if constructed as several independent sketches.
Public property Static member TooManySlopes There is more than one slope defined.
Public property Static member TooManySlopesError There is more than one slope defined.
Public property Static member TrussClosedReference Truss references (chains of one or more reference lines) should not form closed loops."
Public property Static member TrussCrossingReferences Truss top and bottom references cannot cross.
Public property Static member TrussMissingReference Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
Public property Static member TrussOverlappingReference Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
Public property Static member TrussSegmentedReference Truss reference must form a continuous chain of one or more sketch lines.
Public property Static member TrussShiftedReferences Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
Public property Static member TrussSwappedReferences Truss top reference must be above the bottom reference.
Public property Static member UnsatisfiedSupportAssocProp Constraint between a Line created with Pick Support and the Support is not satisfied.
Public property Static member UnsatisfiedWallAssocProp Constraint between a Line created with Pick Wall and the Wall is not satisfied.
Public property Static member VarSketchFailure Constraints defined by highlighted Lines and Dimensions can't be satisfied.
Public property Static member VarSketchInElementFailure The constraints of the sketch defining the highlighted element cannot be satisfied.
Public property Static member WrongCutBoundaryLoops Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
Public property Static member WrongFaceSplitterLoopTypesNum Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.
Top
See Also