Global |
Tests whether a dimension can be labeled by the global parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- dimensionId ElementId
- Id of a dimension element.
Return Value
BooleanTrue of the input dimension can be labeled by this global parameter; False oterwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Possible causes include a dimension that cannot be labeled at all, or it is of other than Linear or Angular type, or does not have the appropriate labeling parameter. Another reason for this method returning False is that the data type of this global parameter is not suitable for labeling (i.e. it contains neither Length nor Angle value), or the parameter is reporting and the dimension has more than one segment.