GetAllExternalFileReferences Method


External File Utils Get All External File References Method

Gets the ids of all elements which are external file references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetAllExternalFileReferences(
	Document aDoc
)

Parameters

aDoc Document
A Revit Document.

Return Value

ICollection ElementId
The ids of all elements which are external file references.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function will not return the ids of nested Revit links; it only returns top-level references.
See Also