SetServicePaletteExclusions Method


Fabrication Service Set Service Palette Exclusions Method

Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetServicePaletteExclusions(
	IList<int> excludedPalettes
)

Parameters

excludedPalettes IList Int32
A list of service palette indexes to be excluded.

Return Value

Boolean
Returns true if succeeded to set the exclusions to the specified palette(s).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException Palette indices contains an index that is not larger or equal to 0 and less than PaletteCount.
See Also