SpliceTypeId Property


Rebar Splice Options Splice Type Id Property

Identifies the id of the Rebar Splice Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId SpliceTypeId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The provided spliceTypeId is not a Rebar Splice Type id. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils .
See Also