RebarInSystem Class


Rebar In System Class

Represents a rebar element that is part of a system.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure RebarInSystem

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarInSystem : Element

The RebarInSystem type exposes the following members.

Properties
Name Description
Public property ArrayLength Identifies the distribution path length of rebar set.
Public property BarsOnNormalSide Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal. For the current implementation of RebarInSystem, this property will always return true, but it is included in the RebarInSystem interface for consistency with the Rebar class.
Public property LayoutRule Identifies the layout rule of rebar set.
Public property MaxSpacing Identifies the maximum spacing between rebar in rebar set.
Public property Normal A unit-length vector normal to the plane of the rebar
Public property NumberOfBarPositions The number of bar positions available in the rebar.
Public property Quantity Identifies the number of bars in rebar set.
Public property RebarShapeId The RebarShape element that defines the shape of the rebar.
Public property ScheduleMark The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property SystemId The Id of an AreaReinforcement or PathReinforcement element that owns this element.
Public property TotalLength The length of an individual bar multiplied by Quantity.
Public property Volume The volume of an individual bar multiplied by Quantity.
Top
Methods
Name Description
Public method CanApplyPresentationMode Checks if a presentation mode can be applied for this rebar in the given view.
Public method CanEditIndividualBars Checks if individual bars can be moved, excluded or included.
Public method ClearPresentationMode Sets the presentation mode for this rebar set to the default (either for a single view, or for all views).
Public method DoesBarExistAtPosition Checks whether a bar is included at the specified position.
Public method FindMatchingPredefinedPresentationMode Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Public method GetBarIndexFromReference Given a reference that represents a part of a bar, this method will return the bar index.
Public method GetBarPositionTransform Return a transform representing the relative position of any individual bar in the set.
Public method GetBendData Gets the RebarBendData, containing bar and hook information, of the instance.
Public method GetCenterlineCurves A chain of curves representing the centerline of the rebar.
Public method GetDistributionPath The distribution path of a rebar set.
Public method GetHookTypeId Get the id of the RebarHookType to be applied to the rebar.
Public method GetHostId The element that contains the rebar.
Public method GetMovedBarTransform Returns a transform representing the movement of the bar relative to its default position along the distribution path.
Public method GetPresentationMode Gets the presentaion mode for this rebar set when displayed in the given view.
Public method GetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public method GetTransformedCenterlineCurves A chain of curves representing the centerline of the rebar.
Public method HasPresentationOverrides Identifies if this RebarInSystem has overridden default presentation settings for the given view.
Public method IsBarHidden Identifies if a given bar in this rebar set is hidden in this view.
Public method IsRebarInSection Identifies if this RebarInSystem is cut by the view plane of the given view.
Public method IsUnobscuredInView Checks if this rebar element is shown unobscured in a view.
Public method MoveBarInSet This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.
Public method ResetMovedBarTransform Reset the transformation representing the movement of the bar relative to its default position along the distribution path. The moved bar transform will be set to Identity.
Public method SetBarHiddenStatus Sets the bar in this rebar set to be hidden or unhidden in the given view.
Public method SetBarIncluded Sets if the bar at the desired index is included or not.
Public method SetPresentationMode Sets the presentation mode for this rebar set when displayed in the given view.
Public method SetUnobscuredInView Sets RebarInSystem element to be shown unobscured in a view.
Top
Remarks
A RebarInSystem element is part of another element, the "system", which controls most of its properties. The system elements are AreaReinforcement and PathReinforcement. Only a few properties of RebarInSystem are modifiable. Otherwise, the appearance and behavior of RebarInSystem elements is identical to Rebar elements. RebarInSystem elements may be converted to Rebar elements by removing the system element.
See Also