RebarInSystem Class


Rebar In System Class

Represents a rebar element that is part of a system.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure RebarInSystem

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarInSystem : Element

The RebarInSystem type exposes the following members.

Properties
Name Description
Public property ArrayLength Identifies the distribution path length of rebar set.
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property BarsOnNormalSide Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal. For the current implementation of RebarInSystem, this property will always return true, but it is included in the RebarInSystem interface for consistency with the Rebar class.
Public property Code example BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property Code example CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property Code example DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property Code example DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property Code example Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property Code example Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LayoutRule Identifies the layout rule of rebar set.
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property Code example Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property MaxSpacing Identifies the maximum spacing between rebar in rebar set.
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property Normal A unit-length vector normal to the plane of the rebar
Public property NumberOfBarPositions The number of bar positions available in the rebar.
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Code example Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Code example Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property Quantity Identifies the number of bars in rebar set.
Public property RebarShapeId The RebarShape element that defines the shape of the rebar.
Public property ScheduleMark The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property SystemId The Id of an AreaReinforcement or PathReinforcement element that owns this element.
Public property TotalLength The length of an individual bar multiplied by Quantity.
Public property Code example UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property Volume The volume of an individual bar multiplied by Quantity.
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanApplyPresentationMode Checks if a presentation mode can be applied for this rebar in the given view.
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanEditIndividualBars Checks if individual bars can be moved, excluded or included.
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method ClearPresentationMode Sets the presentation mode for this rebar set to the default (either for a single view, or for all views).
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method DoesBarExistAtPosition Checks whether a bar is included at the specified position.
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element )
Public method FindMatchingPredefinedPresentationMode Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Public method GetBarIndexFromReference Given a reference that represents a part of a bar, this method will return the bar index.
Public method GetBarPositionTransform Return a transform representing the relative position of any individual bar in the set.
Public method GetBendData Gets the RebarBendData, containing bar and hook information, of the instance.
Public method GetCenterlineCurves A chain of curves representing the centerline of the rebar.
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetDistributionPath The distribution path of a rebar set.
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method Code example GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetHookTypeId Get the id of the RebarHookType to be applied to the rebar.
Public method GetHostId The element that contains the rebar.
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetMovedBarTransform Returns a transform representing the movement of the bar relative to its default position along the distribution path.
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetPresentationMode Gets the presentaion mode for this rebar set when displayed in the given view.
Public method GetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetTransformedCenterlineCurves A chain of curves representing the centerline of the rebar.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Code example GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method HasPresentationOverrides Identifies if this RebarInSystem has overridden default presentation settings for the given view.
Public method IsBarHidden Identifies if a given bar in this rebar set is hidden in this view.
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method IsRebarInSection Identifies if this RebarInSystem is cut by the view plane of the given view.
Public method IsUnobscuredInView Checks if this rebar element is shown unobscured in a view.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method MoveBarInSet This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method ResetMovedBarTransform Reset the transformation representing the movement of the bar relative to its default position along the distribution path. The moved bar transform will be set to Identity.
Public method SetBarHiddenStatus Sets the bar in this rebar set to be hidden or unhidden in the given view.
Public method SetBarIncluded Sets if the bar at the desired index is included or not.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method SetPresentationMode Sets the presentation mode for this rebar set when displayed in the given view.
Public method SetUnobscuredInView Sets RebarInSystem element to be shown unobscured in a view.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A RebarInSystem element is part of another element, the "system", which controls most of its properties. The system elements are AreaReinforcement and PathReinforcement. Only a few properties of RebarInSystem are modifiable. Otherwise, the appearance and behavior of RebarInSystem elements is identical to Rebar elements. RebarInSystem elements may be converted to Rebar elements by removing the system element.
See Also