Layout |
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB LayoutRule
Autodesk.Revit.DB LayoutRuleClearSpacing
Autodesk.Revit.DB LayoutRuleFixedDistance
Autodesk.Revit.DB LayoutRuleFixedNumber
Autodesk.Revit.DB LayoutRuleMaximumSpacing
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB LayoutRule
Autodesk.Revit.DB LayoutRuleClearSpacing
Autodesk.Revit.DB LayoutRuleFixedDistance
Autodesk.Revit.DB LayoutRuleFixedNumber
Autodesk.Revit.DB LayoutRuleMaximumSpacing
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LayoutRule type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

This class just used as the base class of those concrete LayoutRule classes.