MassInstanceUtils Class


Mass Instance Utils Class

A static class that contains methods for processing curves driven by points.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB MassInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MassInstanceUtils : IDisposable

The MassInstanceUtils type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member AddMassLevelDataToMassInstance Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method Dispose Releases all resources used by the MassInstanceUtils
Public method Static member GetGrossFloorArea Get the total occupiable floor area represented by a mass instance.
Public method Static member GetGrossSurfaceArea Get the total exterior building surface area represented by a mass instance.
Public method Static member GetGrossVolume Get the total building volume represented by a mass instance.
Public method Static member GetJoinedElementIds Get the ElementIds of Elements that are joined to a mass instance.
Public method Static member GetMassLevelDataIds Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
Public method Static member GetMassLevelIds Get the ElementIds of the Levels associated with a mass instance.
Public method Static member RemoveMassLevelDataFromMassInstance Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Top
See Also