MassDisplayTemporaryOverride Property


Document Mass Display Temporary Override Property

This setting controls temporary display in views of objects with mass category or subcategories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride { get; set; }

Property Value

MassDisplayTemporaryOverrideType
The MassDisplayTemporaryOverrideType that is active.
Exceptions
Exception Condition
ArgumentException When setting this property: The MassDisplayTemporaryOverrideType::Enum value is not in the proper range.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This setting is temporary and is not stored in the document. The mass display overrides allow mass category and certain mass subcategories to be displayed in all views, regardless of the visibility settings of that view. The settings that show certain mass subcategories will also force the other mass subcategories to be hidden.
See Also