Document New |
Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FamilyInstance NewTeeFitting(
Connector connector1,
Connector connector2,
Connector connector3
)
Parameters
- connector1 Connector
- The first connector to be connected to the tee.
- connector2 Connector
- The second connector to be connected to the tee.
- connector3 Connector
- The third connector to be connected to the tee. This should be connected to the branch of the tee.
Return Value
FamilyInstanceIf creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors' end if necessary, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument connector1, connector2 or connector3 is . |
ArgumentException | Thrown when the connectors cannot be used for the tee creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe. |
InvalidOperationException | Thrown when tee fitting cannot be created. |