ConnectPipePlaceholdersAtTee Method (Document, Connector, Connector, Connector)


Plumbing Utils Connect Pipe Placeholders At Tee(Document, Connector, Connector, Connector) Method

Connects three placeholders that looks like Tee connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ConnectPipePlaceholdersAtTee(
	Document document,
	Connector connector1,
	Connector connector2,
	Connector connector3
)

Parameters

document Document
The document.
connector1 Connector
The first end connector of placeholder to be connected to the second.
connector2 Connector
The second end connector of placeholder to be connected to the first.
connector3 Connector
The third end connector of placeholder to be connected to the first or second.

Return Value

Boolean
True if connection succeeds, false otherwise.
Exceptions
Exception Condition
ArgumentException The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end.
ArgumentNullException A non-optional argument was null
Remarks
The three placeholders may or may not have physically connections. However, the first one should be collinear with the second and third one must have intersection with first and second. If first placeholder and second placeholder have the same size, the second one is merged with first one and original placeholder element will be invalid. If connection fails, the placeholders cannot be physically connected.
See Also