Family |
Sets the structural section in element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- structuralSection StructuralSection
- Structural section with values that will be set.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FamilySymbol cannot have a structural section. |

Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.