Label |
Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static string GetLabelFor(
BuiltInParameter builtInParam,
LanguageType language
)
Parameters
- builtInParam BuiltInParameter
- The BuiltInParameter to get the user-visible name.
- language LanguageType
- The desired LanguageType to get the user-visible name in.
Return Value
StringThe BuiltInParameter name in the desired LanguageType.

Exception | Condition |
---|---|
InvalidOperationException | Thrown when the BuiltInParameter cannot be found. |
InvalidOperationException | Thrown when the desired LanguageType cannot be found for the BuiltInParameter name. |