RebarPropagation Class


Rebar Propagation Class

An utility class containing functions that can be used to propagate rebar elements.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarPropagation

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RebarPropagation

The RebarPropagation type exposes the following members.

Methods
Name Description
Public method Static member AlignByFace It will copy the source rebars, will align them to the destination face based on the source face and adapt them to destination host.
Public method Static member AlignByHost It will copy the source rebars, will align them in the same way as how the source host is aligned to destination host and will adapt them to the destinaion host.
Top
See Also