GetHCurveTangentAtStation Method


Alignment Get HCurve Tangent At Station Method

Calculate 2d (X and Y components of returned vector) horizontal tangent at given station.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetHCurveTangentAtStation(
	double station
)

Parameters

station Double
Alignment station to calculate 2d horizontal tangent for, in Revit internal model units (standard Imperial feet).

Return Value

XYZ
2d (X and Y components of returned vector) horizontal tangent at given station.
See Also