ExternallyTaggedNonBRep Class


Externally Tagged Non BRep Class

This class is used to create an externally tagged geometry object.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternallyTaggedNonBRep : ExternallyTaggedGeometryObject

The ExternallyTaggedNonBRep type exposes the following members.

Constructors
Name Description
Public method ExternallyTaggedNonBRep Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.
Top
Properties
Name Description
Public property ExternalId The external Id of the geometry object.
(Inherited from ExternallyTaggedGeometryObject )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternallyTaggedGeometryObject )
Top
Methods
Name Description
Public method Dispose
(Inherited from ExternallyTaggedGeometryObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetUsage Controls the usage of this ExternallyTaggedNonBRep.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also