AppendShape Method (IList(GeometryObject))


Direct Shape Append Shape(IList Geometry Object ) Method

Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AppendShape(
	IList<GeometryObject> pGeomArr
)

Parameters

pGeomArr IList GeometryObject
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
Exception Condition
ArgumentException At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException A non-optional argument was null
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
See Also