SetRebarShapeId Method


Rebar Shape Driven Accessor Set Rebar Shape Id Method

Changes the RebarShape element that defines the shape of the rebar. Changing the value of this member causes the Rebar instance to choose values for its shape parameters to preserve its previous shape as closely as possible

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetRebarShapeId(
	ElementId shapeId
)

Parameters

shapeId ElementId
Exceptions
Exception Condition
ArgumentException shapeId is not the id of a RebarShape in the document.
ArgumentNullException A non-optional argument was null
InvalidOperationException This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.
See Also