ValidateConnectionsForAllFabricationParts Method


Fabrication Configuration Validate Connections For All Fabrication Parts Method

Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ConnectionValidationInfo ValidateConnectionsForAllFabricationParts(
	bool updateGapForStraights
)

Parameters

updateGapForStraights Boolean
Attempt to update straights to remove the gap between the connctors.

Return Value

ConnectionValidationInfo
The information about the validation check.
Exceptions
Exception Condition
InvalidOperationException this operation failed.
Remarks
If set to update straights any updated straights will be added to a set of element identifiers. Call GetUpdatedStraightsFromValidateConnections to get the set of element identifiers for the updated straights.
See Also