Temporary |
Tests whether a temporary view mode is currently available in the associated view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- mode TemporaryViewMode
- The mode to evaluate
Return Value
BooleanTrue of the temporary mode is currently available in the associated view.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

Not every mode is available in all views at all times. Some of the modes are only available in certain views, or only at certain time/context. Modes that are not available will not be visible on the view's tool bar in the UI.
Even modes that are available do not have to be currently enabled in the current context. Before using a mode its applicability should be tested by calling IsModeEnabled(TemporaryViewMode) .