GetSplittingCurves Method (Document, ElementId, Plane)


Part Utils Get Splitting Curves(Document, Element Id, Plane ) Method

Identifies the curves that were used to create the part and the plane in which they reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<Curve> GetSplittingCurves(
	Document document,
	ElementId partId,
	out Plane sketchPlane
)

Parameters

document Document
The source document of the part.
partId ElementId
The part id.
sketchPlane Plane
The plane in which the division curves were sketched.

Return Value

IList Curve
The curves that created the part. Empty if partId is not a part or Part is not divided.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Example
public void GetCurveDividersAndPlane(Part part)
{
   StringBuilder message = new StringBuilder();
   Plane skP = Plane.CreateByThreePoints(new XYZ(0, 0, 1), new XYZ(1, 0, 0), new XYZ(0, 1, 0));

   // Get curve dividers.
   IList<Curve> divisionCurves = PartUtils.GetSplittingCurves(part.Document, part.Id, out skP);

   if(divisionCurves.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      if(divisionCurves.Count > 0)
         message.AppendLine(divisionCurves.Count.ToString() + " division curves");
   }

   TaskDialog.Show("Revit", message.ToString());
}
See Also