Curve |
This method tests whether this and the given curve elements are joined at the given end.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- end Int32
- Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
- other ElementId
- ElementId of another Curve Element from the same document.
Return Value
BooleanReturns True if the input curve element joins This curve element at the given end-point; returns False otherwise.

Exception | Condition |
---|---|
ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. |
ArgumentNullException | A non-optional argument was null |

The input end is relative to this curve element. The other curve element can be joined at any of its end-points.