GetExternalResourceReferencesFromFailedLoads Method


Link Load Result Get External Resource References From Failed Loads Method

Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ExternalResourceReference> GetExternalResourceReferencesFromFailedLoads()

Return Value

IList ExternalResourceReference
A collection of link ExternalResourceReferences which failed to load.
Remarks

In cases, where a nested structure of several links were loaded, this method is intended to be a convenient way for IExternalResourceUIServers to determine whether a top-level link, or any sub-link, which failed to load properly was provided by their IExternalResourceServer or another server.

If this link and all nested links loaded successfully, then an empty list is returned.

See Also