ViewDisplaySketchyLines Class


View Display Sketchy Lines Class

Represents the settings for sketchy lines.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ViewDisplaySketchyLines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewDisplaySketchyLines : IDisposable

The ViewDisplaySketchyLines type exposes the following members.

Properties
Name Description
Public property EnableSketchyLines True to enable sketchy lines visibility. False to disable it.
Public property Extension The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Jitter The jitter defines jitteriness of the line. Values between 0 and 10.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ViewDisplaySketchyLines
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also