Mechanical |
Connects a group of placeholders that can intersect in a Cross connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool ConnectDuctPlaceholdersAtCross(
Document document,
Connector connector1,
Connector connector2,
Connector connector3,
Connector connector4
)
Parameters
- document Document
- The document.
- connector1 Connector
- The end connector of the first placeholder.
- connector2 Connector
- The end connector of the second placeholder.
- connector3 Connector
- The end connector of the third placeholder.
- connector4 Connector
- The end connector of the fourth placeholder.
Return Value
BooleanTrue if connection succeeds, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end. -or- The curves of connector3 and connector4 are not collinear or either the connecto1 or connector2 is not connector of curve end. |
ArgumentNullException | A non-optional argument was null |

The placeholders may or may not have physical connection. However:
- The ends of four connectors should intersect at same point.
- The first and second placeholders should be collinear each other.
- The third and fourth placeholders should be collinear each other.
- The third and fourth should have intersection with first or second placeholder.