BRepBuilderPersistentIds Class


BRep Builder Persistent Ids Class

This class stores a map from ExternalGeometryIds to BRepBuilderGeometryIds.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BRepBuilderPersistentIds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BRepBuilderPersistentIds : IDisposable

The BRepBuilderPersistentIds type exposes the following members.

Constructors
Name Description
Public method BRepBuilderPersistentIds Constructs a new BRepBuilderPersistentIds and associates the existing BRepBuilder to it.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddSubTag Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method Dispose Releases all resources used by the BRepBuilderPersistentIds
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsAssociatedBRepBuilderValid Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method IsBRepBuilderGeometryIdFaceOrEdge Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method IsValidBRepBuilderGeometryIdForNewCorrespondence Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method IsValidExternalGeometryIdForNewCorrespondence Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also