Filled |
Creates a view-specific filled region from the given boundaries.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FilledRegion Create(
Document document,
ElementId typeId,
ElementId viewId,
IList<CurveLoop> boundaries
)
Parameters
- document Document
- The document in which to create the filled region.
- typeId ElementId
- The filled region type Id.
- viewId ElementId
- The view Id.
- boundaries IList CurveLoop
- The boundaries.
Return Value
FilledRegionThe newly created filled region.

Exception | Condition |
---|---|
ArgumentException | The document is a 3d model family. -or- The Id typeId is invalid. -or- Details can't be drawn in the view. -or- Masking regions and Filled regions can't be created in this document or view. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the view's detail sketch plane; or input curves contain at least one helical curve. -or- Thrown if the viewId or typeId is invalid, or the view does not support the detail items creation, or if the boundaries are empty, open, or self-intersecting. |
ArgumentNullException | A non-optional argument was null |

View-specific filled regions can be created in models and 2d families. The line style of the boundaries will be set to thin lines by default.