CancellationListener Class


Cancellation Listener Class

Allows clients to poll the cancellation status of a background operation. Revit instantiates CancellationListener objects for internal background operation implementations only. As such, third-party developers are not expected to instantiate or handle CancellationListener objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CancellationListener

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CancellationListener : IDisposable

The CancellationListener type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CancellationListener
Public method IsCancelled Returns true if the operation associated with this instance has been cancelled.
Top
See Also