Failure |
Sets the additional reference elements for the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FailureMessage SetAdditionalElements(
ICollection<ElementId> additionalElements
)
Parameters
- additionalElements ICollection ElementId
- The additional elements.
Return Value
FailureMessageThe FailureMessage.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FailureMessage is already posted to a document |

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.