Family |
Remove an existing family parameter from the family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familyParameter FamilyParameter
- The family parameter.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"familyParameter"-is . |
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter. |
InvalidOperationException | Thrown when the family parameter deletion failed. |

Only family and shared parameters may be removed, built-in parameters may not be removed. If the parameter is used in any formulas, those formulas will be automatically removed along with the parameter.