LeaderShoulderPosition Property


Spot Dimension Leader Shoulder Position Property

Position of spot dimension's leader shoulder point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ LeaderShoulderPosition { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException Dimension must have leader. -or- Dimension's leader must have shoulder. -or- Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- The dimension is a SpotSlope or has no leader or leader has no shoulder.
Remarks
Setting of this property also affects LeaderEndPosition and TextPosition.
See Also