GetStairsPath Method


Stairs Run Get Stairs Path Method

Returns the stairs path curves on the run. The curves are projected on base level of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CurveLoop GetStairsPath()

Return Value

CurveLoop
The stairs path curves.
Exceptions
Exception Condition
InvalidOperationException The stairs run has no stairs path it probably because the run was not generated yet.
See Also