AddItems Method


Radio Button Group Add Items Method

Adds new ToggleButtons to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ToggleButton> AddItems(
	IList<ToggleButtonData> buttonData
)

Parameters

buttonData IList ToggleButtonData
A list of objects containing the data needed to construct the ToggleButtons.

Return Value

IList ToggleButton
The newly added ToggleButtons.
Exceptions
Exception Condition
ArgumentNullException Thrown when buttonData is .
ArgumentException Thrown when button with buttonData.Name already exists in the group.
See Also