AddMemberIds Method


Assembly Instance Add Member Ids Method

Adds member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddMemberIds(
	ICollection<ElementId> memberIds
)

Parameters

memberIds ICollection ElementId
Element ids to be added to the assembly instance.
Exceptions
Exception Condition
ArgumentException One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own.
ArgumentNullException A non-optional argument was null
See Also