AsInteger Method


Family Type As Integer Method

Provides access to the integer number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int? AsInteger(
	FamilyParameter familyParameter
)

Parameters

familyParameter FamilyParameter

Return Value

Nullable Int32
The integer value contained in the parameter. Returns if the storage type of the input argument is not integer type or this parameter has no value.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument-"familyParameter"-is .
ArgumentException Thrown if the input argument-"familyParameter"-is invalid,
See Also