TessellatedShapeBuilderFallback Enumeration


Tessellated Shape Builder Fallback Enumeration

Describes what TessellatedShapeBuilder function should do, if it cannot build a requested TessellatedShapeBuilderTarget .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum TessellatedShapeBuilderFallback
Members
Member name Value Description
Abort 0 Do nothing.
Salvage 1 Ignore invalid data, and use all valid data. Note that if a complete set of data describes a solid and some data are ignored, then the result will be a sheet and not a solid.
Mesh 2 If a requested geometrical object cannot be built using all data from the face set(s), create a mesh while using as much data from the face set(s) as possible.
See Also