Rebar |
Sets if the lap length is auto calculated or not for the specified Rebar Splice Type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetAutoCalculatedLapLength(
ElementId rebarSpliceTypeId,
bool autoCalculated
)
Parameters
- rebarSpliceTypeId ElementId
- The Rebar Splice Type id. Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils .
- autoCalculated Boolean
- True, if the lap length is auto calculated, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category. |
ArgumentNullException | A non-optional argument was null |

If it is auto calculated, lap length value is computed based on the formula: lap length multiplier (found in splice type) * bar nominal diameter.