AddSpatialFieldPrimitive Method (Reference, SpatialFieldPrimitiveHideMode)


Spatial Field Manager Add Spatial Field Primitive(Reference, Spatial Field Primitive Hide Mode) Method

Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int AddSpatialFieldPrimitive(
	Reference reference,
	SpatialFieldPrimitiveHideMode hidingMode
)

Parameters

reference Reference
Reference pointing to the curve or face to be associated with the primitive
hidingMode SpatialFieldPrimitiveHideMode
The mode used to hide the original model element

Return Value

Int32
Unique index of primitive for future references
Exceptions
Exception Condition
ArgumentException reference points to neither face nor curve
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

See Also