PanelScheduleTemplate Class


Panel Schedule Template Class

The PanelScheduleTemplate class represents an instance of panel schedule template element. An instance object could be a branch panel, a switchboard or a data panel template.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Electrical PanelScheduleTemplate

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PanelScheduleTemplate : Element

The PanelScheduleTemplate type exposes the following members.

Properties
Name Description
Public property IsBranchPanelSchedule Checks to see if this object is branch panel schedule template element.
Public property IsDataPanelSchedule Checks to see if this object is data panel schedule template element.
Public property IsDefault Checks to see if this is default template for the given panel schedule type.
Public property IsSwitchboardSchedule Checks to see if this object is switchboard schedule template element.
Top
Methods
Name Description
Public method CopyFrom Copies all values from other element to this object.
Public method Static member Create Creates a new instance of a panel schedule template.
Public method GetPanelScheduleType Returns the panel schedule type.
Public method GetSectionData Gets the writable section data object.
Public method GetTableData Gets the writable table data object.
Public method HasSameType Checks if given template has the same panel schedule type with this template.
Public method Static member IsValidPanelConfiguration Checks if given panel configuration is valid for given panel schedule type.
Public method Static member IsValidType(PanelScheduleType) Checks if given type is valid for this panel schedule template element.
Public method SetTableData Assigns table data to this template
Top
See Also